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Sage is a Windows 3.x application that displays over 4,000 gems of wisdom.    You can insert 
or embed a Sage Quote in OLE-compatible programs, adjust the fonts and colors of the 
quote messages, add your own, or delete inappropriate items.    The quote window is 
resizeable, and comes up where you last put it.    Sage works with TrueType, ATM and all 
other Windows scaleable-font programs.

Copyright Info
What's New
Version Info

To learn how to use Help, press F1.

Actions
Registering the Program
Using Sage and OLE

Commands
File Menu Commands
Edit Menu Commands
Browse Menu Commands
Options Menu Commands
Help Menu Commands
Popup Menu Commands

Information
Sage Database File Format



What's New
If you have used Sage before, you'll find that most things work the same as before, but there
are a few new features you should be aware of.

The Right Mouse Button Acts Differently.
In previous versions, the right mouse button went back to the previous quote.    Now, you'll 
see a popup menu (all the latest rage), with several often-used items in it.    Simply move the
pointer down over the list and release the right mouse button to choose an item.    For more 
info on the right mouse button, click here.

Sage now works with OLE.
OLE lets you copy a quote to a word-processing or spreadsheet document, which seemed 
like a good thing to do at the time.    Overall, this added stuff makes the program a little 
larger, but shouldn't get in the way of those who use Sage as a beginning-of-day program.    
For more info on Sage and OLE, click here.

There is now a menu bar for Sage.
Because much of OLE has to do with standard file operations, a menu bar was inevitable.    
The good news is that you don't have to look at it all the time.    Press the Tab key to toggle 
the menu bar.



Registering the Program
You have obtained an unregistered version of Sage which is being marketed under the 
"Shareware" concept.    As such, it is a fully working version of the product, with complete 
documentation.    In its unregistered state, Sage will display an informative message when it 
is first run. When you register the program with Services Rendered for $10 plus tax, you will 
be free of the startup message and be entitled to 1/2 hour of software support. 

You may register the product by mail with a personal or business check.      To order, select 
"Print Order Form..." from the Sage "Help" menu.    The order form is designed to be folded 
and mailed without an envelope, although you can choose to use one if you prefer.

Address:
      Services Rendered 
      455 14th. Street 
      San Francisco, CA 94103 

You can also order Sage from the Public (software) Library with your MC, Visa, American 
Express or Discover card by calling 800-2424-PsL or 713-524-6394; or by FAX to 713-524-
6398. These numbers are for ordering only. For information about dealer pricing, volume 
discounts, site licensing, shipping of product, returns, latest version number or other 
technical information, please write to Services Rendered at the above address.    Telephone 
or FAX orders are subject to a $4 charge for shipping and handling, which makes the total 
price only $14.

By registering, you receive the following benefits: 

The latest version of the software.
A registration code that removes the startup screen.
1/2 hour of free technical support by the author.
Periodic notification of upgrades and enhancements. 

You are authorized to make as many copies of the un-registered version of the product as 
you would like, and to distribute them freely to individuals or onto bulletin boards.    You 
must, however abide by these two simple rules... that you always include with such 
distribution all of the files that you have received, and not share your registration codes with
anyone.



Using Sage and OLE (Object Linking and Embedding)
You can link or embed a Sage Quote into any Windows program that supports OLE.    

From the "Edit" menu of the other program, choose "Insert Object", and then select "Sage 
Quote".    Sage will then come up with a random quote.    When you are ready to see the 
quote in your document, Choose "Update" from the Sage "File" menu.    When you are 
through customizing your quote, choose "Exit" from the Sage "File" menu.    

To edit the quote that is now inserted into your document, just double-click on the quote.



File Menu Commands
New
Creates a new quote file.
When you choose New, you can save any changes to the quote file you have been working 
on.

Open...
Opens a quote file.
When you choose Open, you can load a saved quote file.

Save
Saves a quote file.
When you choose Save, you can save the current quote in a separate quote file.

Save As...
Saves a quote file under a new name.
When you choose Save As, you can save the current quote under a different name than the 
current name.

Add Quote...
Add a quote to the quote database.
You can add your own gems of wisdom one by one to the quote program by typing Ctrl-A (or 
choose "Add Quote..." from the "File" menu.)    You can specify up to 1000 characters of 
quote and byline information for each quote.    If you want to put a carriage return in the 
middle of a quote or byline, type Ctrl-Enter to go to a new line.    Long quotes may scroll off 
the window as you type them; this is normal.    You can also "Paste" a quote from the 
clipboard.    To make the byline show up correctly, put a " - " between the quote and the 
byline.

Delete Quote...
Delete the current quote.
When you choose Delete Quote, the current quote will be deleted from the quote database.   
This can take some time if you have enabled squishing of the quote database after each 
delete. Squishing is off by default.

Edit Quote File
Edit the quote database file.
When you choose Edit Quote File, you can use Write to edit the entire quote database file.

Import...
Import a sage quote.
When you choose Import, you can copy a quote from an existing Sage quote file.

Exit
Exit Sage.
When you choose Exit, you end the Sage program.    The next time you run Sage, the quote 
window will come up where you last left it.    You can also use the Esc key to exit Sage.



Edit Menu Commands
You can copy a relevant quote to the clipboard, and then to any document.    When the quote
you want to clip is displayed, type Ctrl-C (or choose "Copy" from the "Edit" menu.)

Cut
Cut the current quote for pasting.
When you select Cut, you copy the quote to the clipboard for later pasting into another 
application. In Sage, Cut is the same as Copy.

Copy
Copy the current quote for pasting.
When you select Copy, you copy the quote to the clipboard for later pasting into another 
application.

Paste
Paste a quote from the clipboard.
When you choose Paste, any quote in the clipboard is pasted into the current quote.    To 
make the byline show up correctly, put a " - " between the quote and the byline.



Browse Menu Commands
Next Quote
Get a quote at random from the database of quotes.
When you select Next Quote, Sage will select a quote at random from all the quotes in the 
database and display it. You can also use the Spacebar to advance to the next quote.

Previous Quote
Get the previous quote before the current quote.
When you select Previous Quote, Sage will show the last quote you displayed before the 
currently displayed quote.    Up to 10 previous quotes can be remembered.    You can also use
the Backspace key    to show a previous quote.

Find...
Find a specific quote
You can find a specific quote, or all quotes that feature a specific word.    Just enter the word 
you'd like to find.    Upper and lower case are ignored.    You can find the next quote featuring 
the word by typing Ctrl-E (or choosing "Find Next" from the command menu.)    "Find" will let 
you search only quotes or authors if you want.    Just select the "Quotes" or "Authors" radio 
button to restrict your search.

Find Next
Find the next instance of a word.
Use the Find command to find the first instance of a word im the quote database.    Use Find 
Next to get all the other instances of the word in the database.



Options Menu Commands
Quote Font...
Change the typeface of the quote text.
When you select Quote Font, you will be able to change the typeface, size and color of the 
font used for the quote text.

Byline Font...
Change the typeface of the byline font.
When you select Byline Font, you will be able to change the typeface, size and color of the 
font used for the byline text.    If you don't want the byline displayed, choose the same color 
for both the byline and the background.

Background Color...
Change the background color for the quote.
When you select Background Color, you will be able to change the background color of the 
quote window.

Hide Frame Controls
Get rid of the menu bar and system border.
When you choose Hide Frame Controls, the menu bar and system borders disappear, leaving
you with just your quote on the screen.    To get the controls back, simply hit the Tab key to 
go between these two modes.

Other Options...
Set miscellaneous options.
This dialog box allows you to set several options that change the way Sage works and 
displays quotes.
More Info on Other Options...



Help Menu Commands
Contents
Display the main help index.
When you choose Contents, you will see the main help index for Sage.

Search for Help on...
Search the help database for help on a particular topic.
When you choose Search for Help on, you will be able to see a list of help topics.

How to Use Help
Instructions on using the Help system.
When you choose How to Use Help, you will be able to review instructions on the Help 
program.

About Sage...
See information about Sage, or register the program.
When you choose About Sage, you will see the current version of the program in a dialog 
box.    If you have registered Sage, you will select the Register button to register your copy of
Sage.

Print Order Form
Print the Order Form for Sage
When you select Print Order Form, you will be able to fill out your name, address and 
payment information and then print, fax or phone in your order.



Popup Menu Commands

Use the right mouse button to bring up the popup menu.

Next Quote
Get a quote at random from the database of quotes.
When you select Next Quote, Sage will select a quote at random from all the quotes in the 
database and display it. You can also use the Spacebar to advance to the next quote.

Previous Quote
Get the previous quote before the current quote.
When you select Previous Quote, Sage will show the last quote you displayed before the 
currently displayed quote.    Up to 10 previous quotes can be remembered.    You can also use
the Backspace key    to show a previous quote.

Cut
Cut the current quote for pasting.
When you select Cut, you copy the quote to the clipboard for later pasting into another 
application. In Sage, Cut is the same as Copy.

Copy
Copy the current quote for pasting.
When you select Copy, you copy the quote to the clipboard for later pasting into another 
application.

Paste
Paste a quote from the clipboard.
When you choose Paste, any quote in the clipboard is pasted into the current quote.    To 
make the byline show up correctly, put a " - " between the quote and the byline.

Hide Frame Controls
Get rid of the menu bar and system border.
When you choose Hide Frame Controls, the menu bar and system borders disappear, leaving
you with just your quote on the screen.    To get the controls back, simply hit the Tab key to 
go between these two modes.

Exit
Exit Sage.
When you choose Exit, you end the Sage program.    The next time you run Sage, the quote 
window will come up where you last left it.    You can also use the Esc key to exit Sage.



Other Sage Options

Quote Border Height and Width
These items set the amount of space that stands between a quote and the border.

Shadow Border Width
This item sets the depth of shadow effect applied to the edge of a quote.

Minutes to next quote
Sets how many minutes should elapse before Sage should automatically generate a new 
quote.    1440 minutes is 24 hours.

Scaleable Quotation Marks
If you use scaleable fonts and check the "Scaleable Quotation Marks" checkbox, the quote 
will be surrounded in typographical quote marks instead of the generic vertical quote marks.
Scaleable fonts, created on-the-fly by TrueType or ATM, have these special quote characters. 
If you see a black box, vertical bar or dots instead of quote marks with this option set, the 
font you've chosen does not contain the special quote characters.    Uncheck the box or 
select another scaleable font.

Squish file on delete
You can set whether or not deleting a quote will reduce the size of the quote database with 
the "Squish file on delete" button.    If you check it, Sage will take quite some time 
compressing space in the file after each delete.    The default setting is unchecked, for no 
time-consuming squishing.

Avoid Program Icons
When checked, this item will cause the quote to avoid the lower fifth of the screen when 
displaying, so as not to cover up icons.

Scribe Line Around Quote
When checked, Sage will draw a shadowed line inside the quote display box.

Sizing border Around Quote
When checked, Sage will continue to show a sizing border around a quote, even if the menu 
bar is not showing.

Apply
The "Apply" button will show your the results of your changes without exiting the options 
dialog.





Copyright Statements
Sage is Copyright © 1990-1992 by Services Rendered.    It is distributed as "shareware", i.e., 
you are encouraged to disseminate the software far and wide, providing it is distributed in its
entirety and without charge, except for media and mailing, if applicable.    I expressly reserve
the right to change these distribution restrictions in future versions.    Sage is distributed 
without warranty, either expressed or implied, and without guarantee as to its suitability for 
a particular task. Sage has been tested and performs its functions essentially as 
documented, without causing any damage to the computer in use or any of its files.    
However, all users are responsible for backing up their own files, and Services Rendered 
assumes no responsibility for any damage or losses incurred as a result of its use. 

Portions © 1992 Microsoft Corporation. All rights reserved.
Microsoft is a registered trademark and Windows is a trademark of Microsoft Corporation.
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Version Information and History
03/30/1992 Version 2.0 Sage now supports Object Linking and Embedding, and allows 

you to hide the window frame. Lots of additional formatting 
features.

03/01/1992 Version 1.6 You can now use Microsoft Write to edit the entire quote file.    
Just choose "Edit Quote File" from the "File" menu.

10/10/1991 Version 1.5 Default font names were adjusted for the TrueType fonts of 
Windows 3.1, and common dialog boxes are now used for font 
and color selection. A pesky font display bug is now fixed. You 
can now paste added quotes from the clipboard.

08/31/1991 Version 1.4 The size of internal tables are enlarged for better handling of 
"loaded" Windows users, i.e., those with lots of startup 
programs.    Also, there is a new "Delete Quote" option. Tested a 
lot before release.

03/19/1991 Version 1.3 "Find" will now let you search only quotes or authors if you 
want.    The "Options" menu will now let you choose to avoid 
covering up icons at the bottom of your screen. You can add 
quotes to your database from an additions file (SAGE.ADD). You 
can also order Sage using a credit card, which makes telephone 
and FAX ordering a convenient alternative to checks.

01/01/1991 Version 1.2 "Find" will now find comment lines, memory access cleaned up, 
PostScript printer better supported, more foreground color 
choices, and even more quotes!

11/25/1990 Version 1.1 Added more background color choices
11/18/1990 Version 1.0 Initial release



Sage Database File Format
If you want, you can add your own gems of wisdom manually.    The quote text file SAGE.DAT 
is fully editable using any text editor, and can contain any number of quotes.    To edit the file
using Microsoft Write, choose "Edit Quote File" from the "File" menu.

Comment lines, which are never displayed, start with two slashes, like this:
// This is a comment,
// and this is another.

Each quote has its own line, and looks like this:
Neuroses are red,^Melancholia's blue.
"Furious activity is no substitute for understanding." - H. H. Williams^In The Observer, 1866

(If these examples are wrapping on your display, it is not intentional.    They should each be 
on their own line.)
Each Quote can be surrounded by quote marks (if you like.)    The byline always starts with a 
space, a dash, and another space.    If you need to have a dash in your text, put two in a row,
like this:
"A billion here, a billion there -- pretty soon it adds up to real money!"

You can cause a new line to appear when the quote is displayed with the caret key (^). Both 
the quote and any byline can have carets.




